Problem Description
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
Output
For each case, output the minimum times need to sort it in ascending order on a single line.
Sample Input
Sample Output
也是水题一道
自己写个冒泡然后统计次数就OK了
#include <stdio.h>
int sort(int *a,int n)
{
int i,j,t,cnt = 0;
for(i = 0;i<n-1;i++)
{
for(j = 0;j<n-1-i;j++)
{
if(a[j]>a[j+1])
{
t = a[j];
a[j] = a[j+1];
a[j+1] = t;
cnt++;
}
}
}
return cnt;
}
int main()
{
int a[1005];
int n,i;
while(~scanf("%d",&n))
{
for(i = 0;i<n;i++)
scanf("%d",&a[i]);
printf("%d\n",sort(a,n));
}
return 0;
}