为了不占太多篇数,就把部分写在一起啦!
1011: C语言程序设计教程(第三版)课后习题6.1
题目描述
输入两个正整数m和n,求其最大公约数和最小公倍数。
输入
两个整数
输出
最大公约数,最小公倍数
样例输入
5 7
样例输出
1 35
#include<stdio.h>
int commonDivisor(int a, int b){
int min = (a>b)?b:a;
int i = min;
for(; i>0; i--){
if(!(a%i)&&!(b%i)){
return i;
break;
}
}
}
int commonMultiple(int a, int b){
int max = (a>b)?a:b;
int i = max;
for(; ; i++){
if(!(i%a)&&!(i%b)){
return i;
break;
}
}
}
int main()
{
int m, n;
scanf("%d%d", &m, &n);
printf("%d %d\n", commonDivisor(m, n), commonMultiple(m, n));
return 0;
}
1012: C语言程序设计教程(第三版)课后习题6.2
题目描述
输入一行字符,分别统计出其中英文字母、数字、空格和其他字符的个数。
输入
一行字符
输出
统计值
样例输入
aklsjflj123 sadf918u324 asdf91u32oasdf/.’;123
样例输出
23 16 2 4
#include<stdio.h>
#define N 100
int main()
{
int character, a = 0, b = 0, c = 0, d = 0;
while((character = getchar())!='\n'){
if((character>='a' && character<='z') || (character>='A' && character<='Z')){
a++;
} else if(character>=48 && (int)character<=57) {
b++;
} else if(character == ' ') {
c++;
} else {
d++;
}
}
printf("%d %d %d %d\n", a, b, c, d);
return 0;
}