Description
有 n n n个 f a c e face face和 m m m个 b o d y body body,给出 k k k种配对对应的权值,一个 b o d y body body只能配一个 f a c e face face,但一个 f a c e face face可以配多个 b o d y body body,问合法匹配的最大权值和
Input
第一行一整数 T T T表示用例组数,每组用例输入三个整数 n , m , k n,m,k n,m,k,之后 k k k行每行输入三个整数 a i , b i , c i a_i,b_i,c_i ai,bi,ci表示第 a i a_i ai个 f a c e face face配第 b i b_i bi个 b o d y body body的权值为 c i c_i ci
( 1 ≤ T ≤ 5 , 1 ≤ n , m , k ≤ 1 0 5 , 1 ≤ a i ≤ n , 1 ≤ b i ≤ m , 1 ≤ c i ≤ 1 0 9 ) (1\le T\le 5,1\le n,m,k\le 10^5,1\le a_i\le n,1\le b_i\le m,1\le c_i\le 10^9) (1≤T≤5,1≤n,m,k≤105,1≤ai≤n,1≤bi≤m,1≤ci≤109)
Output
输出最大权值和
Sample Input
1
2 3 3
1 2 1919
1 3 810
2 2 450
Sample Output
Case #1: 2729
Solution
给每个 b o d y body body配上权值最大的 f a c e face face即可
Code
#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long ll;
#define maxn 100005
int T,Case=1,n,m,k,mx[maxn];
int main()
{
scanf("%d",&T);
while(T--)
{
scanf("%d%d%d",&n,&m,&k);
for(int i=1;i<=m;i++)mx[i]=0;
while(k--)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
mx[b]=max(mx[b],c);
}
ll ans=0;
for(int i=1;i<=m;i++)ans+=mx[i];
printf("Case #%d: %lld\n",Case++,ans);
}
return 0;
}