Bone Collector
题目描述
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
输入
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
输出
One integer per line representing the maximum of the total value (this number will be less than 231).
示例输入
1
5 10
1 2 3 4 5
5 4 3 2 1
示例输出
14
#include <iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int max(int n,int m)
{
return n>m?n:m;
}
int main()
{
int t,n,m,jia[1001],v[1001],f[1001],i,j,k;
scanf("%d",&t);
while(t--)
{
memset(f,0,sizeof(f));
scanf("%d%d",&n,&m);
for(i=0; i<n; i++)
scanf("%d",&jia[i]);
for(j=0; j<n; j++)
scanf("%d",&v[j]);
for(i=0; i<n; i++)//01背包
for(j=m; j>=v[i]; j--)
{
f[j]=max(f[j],f[j-v[i]]+jia[i]);
}
printf("%d\n",f[m]);
}
}