当前位置: 首页 > 工具软件 > Pizza > 使用案例 >

Alfredo's Pizza Restaurant

长孙知
2023-12-01

题目来源:http://218.194.91.48/acmhome/problemdetail.do?&method=showdetail&id=1455

描述

    Traditionally after the Local Contest, judges and contestants go to their favourite restaurant, Alfredos Pizza Restaurant. The contestants are really hungry after trying hard for five hours. To get their pizza as quickly as possible, they just decided to order one big pizza for all instead of several small ones. They wonder whether it is possible to put the big rectangular pizza on the surface of the round table such that it does not overhang the border of the table. Write a program that helps them!

输入

    The input file contains several test cases. Each test case starts with an integer number r, the radius of the surface of the round table the contestants are sitting at. Input is terminated by r=0. Otherwise, 1 ≤ r ≤ 1000. Then follow 2 integer numbers w and l specifying the width and the length of the pizza, 1 ≤ w ≤ l ≤ 1000.

输出

    Output for each test case whether the ordered pizza will fit on the table or not. Adhere to the format shown in the sample output. A pizza which just touches the border of the table without intersecting it is considered fitting on the table, see example 3 for clarification.

样例输入

38 40 60
35 20 70
50 60 80
0

样例输出

Pizza 1 fits on the table.
Pizza 2 does not fit on the table.
Pizza 3 fits on the table.


//此题完全为一水题,问你长方形能不能放进圆里.. 
#include<cstdio>
int main(){
    int a,b,c,id=1;
    while( scanf("%d",&a) && a){
        scanf("%d%d",&b,&c);
        a=a*2;
        if(a*a>=b*b+c*c) printf("Pizza %d fits on the table.\n",id++);
        else printf("Pizza %d does not fit on the table.\n",id++);
    }return 0;
}





 类似资料:

相关阅读

相关文章

相关问答