当前位置: 首页 > 工具软件 > Shining Panda > 使用案例 >

4046 Panda(The 36th ACM/ICPC Asia Regional Beijing Site —— Online Contest)

纪辰沛
2023-12-01

Panda

Problem Description
When I wrote down this letter, you may have been on the airplane to U.S.
We have known for 15 years, which has exceeded one-fifth of my whole life. I still remember the first time we went to the movies, the first time we went for a walk together. I still remember the smiling face you wore when you were dressing in front of the mirror. I love your smile and your shining eyes. When you are with me, every second is wonderful.
The more expectation I had, the more disappointment I got. You said you would like to go to U.S.I know what you really meant. I respect your decision. Gravitation is not responsible for people falling in love. I will always be your best friend. I know the way is difficult. Every minute thinking of giving up, thinking of the reason why you have held on for so long, just keep going on. Whenever you’re having a bad day, remember this: I LOVE YOU.
I will keep waiting, until you come back. Look into my eyes and you will see what you mean to me.
There are two most fortunate stories in my life: one is finally the time I love you exhausted. the other is that long time ago on a particular day I met you.
Saerdna.

It comes back to several years ago. I still remember your immature face.
The yellowed picture under the table might evoke the countless memory. The boy will keep the last appointment with the girl, miss the heavy rain in those years, miss the love in those years. Having tried to conquer the world, only to find that in the end, you are the world. I want to tell you I didn’t forget. Starry night, I will hold you tightly.

Saerdna loves Panda so much, and also you know that Panda has two colors, black and white.
Saerdna wants to share his love with Panda, so he writes a love letter by just black and white.
The love letter is too long and Panda has not that much time to see the whole letter.
But it’s easy to read the letter, because Saerdna hides his love in the letter by using the three continuous key words that are white, black and white.
But Panda doesn’t know how many Saerdna’s love there are in the letter.
Can you help Panda?

Input
An integer T means the number of test cases T<=100
For each test case:
First line is two integers n, m
n means the length of the letter, m means the query of the Panda. n<=50000,m<=10000
The next line has n characters ‘b’ or ‘w’, ‘b’ means black, ‘w’ means white.
The next m lines
Each line has two type
Type 0: answer how many love between L and R. (0<=L<=R < n)
Type 1: change the kth character to ch(0<=k < n and ch is ‘b’ or ‘w’)

Output
For each test case, output the case number first.
The answer of the question.

Sample Input
2

5 2
bwbwb
0 0 4
0 1 3
5 5
wbwbw
0 0 4
0 0 2
0 2 4
1 2 b
0 0 4

Sample Output
Case 1:
1
1
Case 2:
2
1
1
0
用线段树可以做,用树状数组也可以做,我用的树状数组
将三个字母看做一个点,然后判断点的时候要注意题目中的字母是从0开始的

#include<bits/stdc++.h>
using namespace std;
using LL =int64_t;
const int maxn=5e4+5;
int E[maxn];
int n,m;

int lowbit(int x) {return x&-x;}

void add(int num,int x) {
    while(num<=n) {
        E[num]+=x;num+=lowbit(num);
    }
}

int sum(int x) {
    int ret=0;
    while(x>0) {
        ret+=E[x];x-=lowbit(x);
    }
    return ret;
}

int main()
{
    ios::sync_with_stdio(0);
    cin.tie(0);
    int T;
    cin>>T;
    for(int i=1;i<=T;i++) {
        memset(E,0,sizeof(E));
        string s("x");
        string temp;
        cout<<"Case "<<i<<":"<<endl;
        cin>>n>>m;
        cin>>temp;
        s+=temp;
        for(int j=3;j<=n;j++) {
            if(s[j]=='w'&&s[j-1]=='b'&&s[j-2]=='w')
                add(j,1);
        }
        int flag,x,y;
        char c;
        for(int j=0;j<m;j++) {
            cin>>flag;
            if(flag==0) {
                cin>>x>>y;
                if(y-x<2) cout<<0<<endl;
                else cout<<sum(y+1)-sum(x+2)<<endl;
            }
            else if(flag==1) {
                cin>>x>>c;
                x++;
                if(s[x]==c) continue;
                if(x>=3&&s[x-2]=='w'&&s[x-1]=='b'&&s[x]=='w')
                    add(x,-1);
                if(x>=3&&s[x-2]=='w'&&s[x-1]=='b'&&c=='w')
                    add(x,1);
                if(x>=2&&x+1<=n&&s[x-1]=='w'&&s[x]=='b'&&s[x+1]=='w')
                    add(x+1,-1);
                if(x>=2&&x+1<=n&&s[x-1]=='w'&&c=='b'&&s[x+1]=='w')
                    add(x+1,1);
                if(x+2<=n&&s[x]=='w'&&s[x+1]=='b'&&s[x+2]=='w')
                    add(x+2,-1);
                if(x+2<=n&&c=='w'&&s[x+1]=='b'&&s[x+2]=='w')
                    add(x+2,1);
                s[x]=c;
            }
         }
    }
    return 0;
}

其中有一个sum(y+1)-sum(x+2)要注意一下因为是从0开始计数的,然后要本来应该是sum(y+1)-sum(x),但因为如果x有价值的话至少也是x,x+1,x+2组成“wbw”才行,所以是直接减x+2

 类似资料:

相关阅读

相关文章

相关问答