Let’s Chat
Time Limit: 1 Second Memory Limit: 65536 KB
ACM (ACMers’ Chatting Messenger) is a famous instant messaging software developed by Marjar Technology Company. To attract more users, Edward, the boss of Marjar Company, has recently added a new feature to the software. The new feature can be described as follows:
If two users, A and B, have been sending messages to each other on the last m consecutive days, the “friendship point” between them will be increased by 1 point.
More formally, if user A sent messages to user B on each day between the (i - m + 1)-th day and the i-th day (both inclusive), and user B also sent messages to user A on each day between the (i - m + 1)-th day and the i-th day (also both inclusive), the “friendship point” between A and B will be increased by 1 at the end of the i-th day.
Given the chatting logs of two users A and B during n consecutive days, what’s the number of the friendship points between them at the end of the n-th day (given that the initial friendship point between them is 0)?
Input
There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 10), indicating the number of test cases. For each test case:
The first line contains 4 integers n (1 ≤ n ≤ 109), m (1 ≤ m ≤ n), x and y (1 ≤ x, y ≤ 100). The meanings of n and m are described above, while x indicates the number of chatting logs about the messages sent by A to B, and y indicates the number of chatting logs about the messages sent by B to A.
For the following x lines, the i-th line contains 2 integers la, i and ra, i (1 ≤ la, i ≤ ra, i ≤ n), indicating that A sent messages to B on each day between the la, i-th day and the ra, i-th day (both inclusive).
For the following y lines, the i-th line contains 2 integers lb, i and rb, i (1 ≤ lb, i ≤ rb, i ≤ n), indicating that B sent messages to A on each day between the lb, i-th day and the rb, i-th day (both inclusive).
It is guaranteed that for all 1 ≤ i < x, ra, i + 1 < la, i + 1 and for all 1 ≤ i < y, rb, i + 1 < lb, i + 1.
Output
For each test case, output one line containing one integer, indicating the number of friendship points between A and B at the end of the n-th day.
Sample Input
2
10 3 3 2
1 3
5 8
10 10
1 8
10 10
5 3 1 1
1 2
4 5
Sample Output
3
0
Hint
For the first test case, user A and user B send messages to each other on the 1st, 2nd, 3rd, 5th, 6th, 7th, 8th and 10th day. As m = 3, the friendship points between them will be increased by 1 at the end of the 3rd, 7th and 8th day. So the answer is 3.
Author: WENG, Caizhi
Source: The 14th Zhejiang Provincial Collegiate Programming Contest Sponsored by TuSimple
Submit Status
虽然题目保证 1 ≤ i < x, ra, i + 1 < la, i + 1 and for all 1 ≤ i < y, rb, i + 1 < lb, i + 1.
,但可能会出现 [1,3],[3,6]的情况,把类似的两个相邻的区间合并,然后依次遍历两个人的区间,每次取左区间大的l,用右区间小的去减去,保留右区间大的值,并更新左区间为右区间较小的值 + 1,并于右区间较小的下一个区间比较~
AC代码:
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
typedef long long LL;
int a[110];
struct node{
int l,r;
}st1[110],st2[110],s1[110],s2[110];
int main()
{
int T;
scanf("%d",&T);
while(T--){
LL n,m,x,y,la,ra,lb,rb;
scanf("%lld %lld %lld %lld",&n,&m,&x,&y);
int n1 = 0,n2 = 0;
for(int i = 1; i <= x; i++){
scanf("%lld %lld",&la,&lb);
s1[i].l = la,s1[i].r = lb;
}
for(int i = 1; i <= y; i++){
scanf("%lld %lld",&la,&lb);
s2[i].l = la,s2[i].r = lb;
}
LL num = 0;
n1 = n2 = 0;
for(int i = 1; i <= x; i++){
int l = s1[i].l;
while(s1[i].r + 1 == s1[i].l) i++;
int r = s1[i].r;
st1[++n1].l = l,st1[n1].r = r;
}
for(int i = 1; i <= y; i++){
int l = s2[i].l;
while(s2[i].r + 1 == s2[i].l) i++;
int r = s2[i].r;
st2[++n2].l = l,st2[n2].r = r;
}
int j = 1,i = 1;
while(i <= n1 && j <= n2){
if(st1[i].l > st2[j].r){
j++;
continue;
}
if(st2[j].l > st1[i].r){
i++;
continue;
}
int ml = max(st1[i].l,st2[j].l);
int mr = min(st1[i].r,st2[j].r);
if(mr - ml + 1 >= m) num += (mr - ml + 1 - m + 1);
if(st1[i].r < st2[j].r) st2[j].l = st1[i].r + 1,i++;
else if(st1[i].r > st2[j].r) st1[i].l = st2[j].r + 1,j++;
else i++,j++;
}
printf("%lld\n",num);
}
return 0;
}