当前位置: 首页 > 工具软件 > Let's Chat > 使用案例 >

ZOJ 3961Let's Chat

孟浩慨
2023-12-01
Let's Chat

Time Limit: 1 Second       Memory Limit: 65536 KB

ACM (ACMers' Chatting Messenger) is a famous instant messaging software developed by Marjar Technology Company. To attract more users, Edward, the boss of Marjar Company, has recently added a new feature to the software. The new feature can be described as follows:

If two users, A and B, have been sending messages to each other on the last m consecutive days, the "friendship point" between them will be increased by 1 point.

More formally, if user A sent messages to user B on each day between the (i - m + 1)-th day and the i-th day (both inclusive), and user B also sent messages to user A on each day between the (i - m + 1)-th day and the i-th day (also both inclusive), the "friendship point" between A and B will be increased by 1 at the end of the i-th day.

Given the chatting logs of two users A and B during n consecutive days, what's the number of the friendship points between them at the end of the n-th day (given that the initial friendship point between them is 0)?

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 10), indicating the number of test cases. For each test case:

The first line contains 4 integers n (1 ≤ n ≤ 109), m (1 ≤ m ≤ n), x and y (1 ≤ xy ≤ 100). The meanings of n and m are described above, while x indicates the number of chatting logs about the messages sent by A to B, and y indicates the number of chatting logs about the messages sent by B to A.

For the following x lines, the i-th line contains 2 integers lai and rai (1 ≤ lai ≤ rai ≤ n), indicating that A sent messages to B on each day between the lai-th day and the rai-th day (both inclusive).

For the following y lines, the i-th line contains 2 integers lbi and rbi (1 ≤ lbi ≤ rbi ≤ n), indicating that B sent messages to A on each day between the lbi-th day and the rbi-th day (both inclusive).

It is guaranteed that for all 1 ≤ i < xrai + 1 < lai + 1 and for all 1 ≤ i < yrbi + 1 < lbi + 1.

Output

For each test case, output one line containing one integer, indicating the number of friendship points between A and B at the end of the n-th day.

Sample Input

2
10 3 3 2
1 3
5 8
10 10
1 8
10 10
5 3 1 1
1 2
4 5

Sample Output

3
0

Hint

For the first test case, user A and user B send messages to each other on the 1st, 2nd, 3rd, 5th, 6th, 7th, 8th and 10th day. As m = 3, the friendship points between them will be increased by 1 at the end of the 3rd, 7th and 8th day. So the answer is 3.

想法:水题

代码:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
using namespace std;
struct node
{
    int l;
    int r;
};
bool cmp(node x,node y)
{
    if(x.l==y.l)
        return x.r<y.r;
    else
        return x.l<y.l;
}
int main()
{
    int T;
    scanf("%d",&T);
    node s1[110];
    node s2[110];
    node s3[110];
    while(T--)
    {
        int n,m,x,y;
      scanf("%d%d%d%d",&n,&m,&x,&y);
      int i,j;
      for(i=0;i<x;i++)
      {
          scanf("%d %d",&s1[i].l,&s1[i].r);
      }
       for(i=0;i<y;i++)
      {
          scanf("%d %d",&s2[i].l,&s2[i].r);
      }
      sort(s1,s1+x,cmp);
      sort(s2,s2+y,cmp);
      /* for(i=0;i<x;i++)
      {
          printf("%d %d\n",s1[i].l,s1[i].r);
      }
      for(i=0;i<y;i++)
      {
          printf("%d %d\n",s2[i].l,s2[i].r);
      }*/
      int k1,k2,count=0;
      for(i=0;i<x;i++)
      {
          for(j=0;j<y;j++)
          {
            k1=max(s1[i].l,s2[j].l);
            k2=min(s1[i].r,s2[j].r);
            if(k2-k1>=m-1)
            {
               count+=k2-k1-(m-1)+1;
               //printf("%d %d\n",k2,k1);
            }
          }
      }
      printf("%d\n",count);
    }
    return 0;
}

 类似资料:

相关阅读

相关文章

相关问答