Let’s Chat
Time Limit: 1 Second Memory Limit: 65536 KB
ACM (ACMers’ Chatting Messenger) is a famous instant messaging software developed by Marjar Technology Company. To attract more users, Edward, the boss of Marjar Company, has recently added a new feature to the software. The new feature can be described as follows:
If two users, A and B, have been sending messages to each other on the last m consecutive days, the “friendship point” between them will be increased by 1 point.
More formally, if user A sent messages to user B on each day between the (i - m + 1)-th day and the i-th day (both inclusive), and user B also sent messages to user A on each day between the (i - m + 1)-th day and the i-th day (also both inclusive), the “friendship point” between A and B will be increased by 1 at the end of the i-th day.
Given the chatting logs of two users A and B during n consecutive days, what’s the number of the friendship points between them at the end of the n-th day (given that the initial friendship point between them is 0)?
Input
There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 10), indicating the number of test cases. For each test case:
The first line contains 4 integers n (1 ≤ n ≤ 109), m (1 ≤ m ≤ n), x and y (1 ≤ x, y ≤ 100). The meanings of n and m are described above, while x indicates the number of chatting logs about the messages sent by A to B, and y indicates the number of chatting logs about the messages sent by B to A.
For the following x lines, the i-th line contains 2 integers la, i and ra, i (1 ≤ la, i ≤ ra, i ≤ n), indicating that A sent messages to B on each day between the la, i-th day and the ra, i-th day (both inclusive).
For the following y lines, the i-th line contains 2 integers lb, i and rb, i (1 ≤ lb, i ≤ rb, i ≤ n), indicating that B sent messages to A on each day between the lb, i-th day and the rb, i-th day (both inclusive).
It is guaranteed that for all 1 ≤ i < x, ra, i + 1 < la, i + 1 and for all 1 ≤ i < y, rb, i + 1 < lb, i + 1.
Output
For each test case, output one line containing one integer, indicating the number of friendship points between A and B at the end of the n-th day.
Sample Input
2
10 3 3 2
1 3
5 8
10 10
1 8
10 10
5 3 1 1
1 2
4 5
Sample Output
3
0
Hint
For the first test case, user A and user B send messages to each other on the 1st, 2nd, 3rd, 5th, 6th, 7th, 8th and 10th day. As m = 3, the friendship points between them will be increased by 1 at the end of the 3rd, 7th and 8th day. So the answer is 3.
#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
struct tx
{
int l, r;
} A[250], B[250];
int main()
{
int n, m, x, y, t, i, j, L, R, s, sum;
cin>>t;
while(t--)
{
sum = 0;
cin>>n>>m>>x>>y;
for(i = 0; i < x;i++)
{
cin>>A[i].l>>A[i].r;
}
for(i = 0; i < y; i++)
{
cin>>B[i].l>>B[i].r;
}
i = 0;
j = 0;
while(i < x && j < y)
{
if(A[i].l > B[j].r)
j++;
if(B[j].l > A[i].r)
i++;
else
{
L = max(A[i].l,B[j].l);
R = min(A[i].r,B[j].r);
if(A[i].r < B[j].r)
i++;
else
j++;
s = R - L + 1;
if(s >= m)
sum = sum + s - m + 1;
}
}
cout<<sum<<endl;
}
return 0;
}