当前位置: 首页 > 工具软件 > Leaves > 使用案例 >

1004 Counting Leaves (30分)

谷梁宁
2023-12-01

1004 Counting Leaves (30分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1
#include <iostream>
#include <algorithm>
#include<vector>
#include<map>
#include<string>
#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<set>
#include<unordered_map>
#include<queue>
#include<climits>
using namespace std;
const int maxn= 10000+5;

vector<int>v[maxn];


int yeap[maxn]={0};

int maxh=INT_MIN;
int root,depth;
void dfs(int root,int depth){
	if(v[root].size()==0){
		yeap[depth]++;
		if(maxh<depth){
			maxh=depth;
		}
		return ;
	}
	for(int i=0;i<v[root].size();i++){
		dfs(v[root][i],depth+1);
	
	}
}	


int main(){
	int n,m,k;
	cin>>n>>m;
	for(int i=0;i<m;i++){
		cin>>root>>k;	
		int id;
		for(int j=0;j<k;j++){
			cin>>id; 
			v[root].push_back(id);	
		}
	}
	dfs(1,0);
	cout<<yeap[0];
	for(int i=1;i<=maxh;i++) cout<<" "<<yeap[i];
	
    return 0;
}

 

 类似资料: