当前位置: 首页 > 工具软件 > Alice > 使用案例 >

1798. Alice and Bob

帅银龙
2023-12-01

1798. Alice and Bob

Description

Bob is very famous because he likes to play games. Today he puts a chessboard in the desktop, and plays a game with Alice. The size of the chessboard is n by n. A stone is placed in a corner square. They play alternatively with Alice having the first move. Each time, player is allowed to move the stone to an unvisited neighbor square horizontally or vertically. The one who can’t make a move will lose the game. If both play perfectly, who will win the game?

Input

The input is a sequence of positive integers each in a separate line. The integers are between 1 and 10000, inclusive, indicating the size of the chessboard. The end of the input is indicated by a zero.

Output

Output the winner (“Alice” or “Bob”) for each input line except the last zero. No other characters should be inserted in the output.

Sample Input

2
0

Sample Output

Alice

// source code of submission 966447, Zhongshan University Online Judge System
#include <stdio.h>

int main()
{
    int n;
    while(scanf("%d", &n) && n)
    {
        if(n % 2 == 0)
            printf("Alice\n");
        else
            printf("Bob\n");
    }
    return 0;
}


 类似资料:

相关阅读

相关文章

相关问答